This package implements Host addresses as described in RFC2396 section 3.2.2 with additional consideration of
- RFC1123 (additional restrictions for hostnames),
- RFC1034 (disambiguate domain names and IPv4 addresses),
- RFC4291 (parsing of IPv6 addresses), and
- RFC3986 and RFC5952 (IPv6 literals within host addresses).
cabal buildThe following optional build flags are available:
-
-fwith-aeson: buildToJSONandFromJSONinstance for use with aeson. -
-fwith-configuration-tools: build instances and functions for supporting the use with configuration-tools. -
-fwith-quickcheck: include function for generating arbitrary values andArbitraryinstance for use with QuickCheck.
Documentation is available at https://hackage.haskell.org/package/hostaddress/.